[Kakasi-dev 147] Re: 新しいautotoolsへの対応

NOKUBI Takatsugu knok @ daionet.gr.jp
2013年 11月 11日 (月) 17:33:27 JST


At Sat, 09 Nov 2013 13:31:27 +0900,
Tadamasa Teranishi wrote:
> 新しいバージョンに対応するということなので、良いことかと思います。
> ちなみに修正後は、古いバージョンだと逆にエラーになったりするので
> しょうか?

  できる限り互換性は保ちたいところですが、場合によっては動かないかもし
れません。

  現状gnomeあたりから持ってきたautogen.shでconfigure関連を生成するよう
になっていますが、新しいものに対応すれば標準付属のautoreconfを実行すれ
ば済むようになります。

  autogen.shは失敗すると「このバージョンのautotoolsを入れろ」的なメッセー
ジがハードコードされているので、もうautogen.shを使わないで済むようにし
たいという事情もあります。


Kakasi-dev メーリングリストの案内